PAT Advanced 1007. Maximum Subsequence Sum (25) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

Given a sequence of K integers { N_1 , N_2 , ..., N_K }. A continuous
subsequence is defined to be { N_i , N_{i+1} , ..., N_j } where 1 \le i \le j \le K . The Maximum Subsequence is the continuous subsequence which has
the largest sum of its elements. For example, given sequence { -2, 11, -4, 13,
-5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being

Now you are supposed to find the largest sum, together with the first and the
last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The
first line contains a positive integer K ( \le 10000 ). The second line
contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the
first and the last numbers of the maximum subsequence. The numbers must be
separated by one space, but there must be no extra space at the end of a line.
In case that the maximum subsequence is not unique, output the one with the
smallest indices i and j (as shown by the sample case). If all the K
numbers are negative, then its maximum sum is defined to be 0, and you are
supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路

可以说是经典算法题目之一了,时间复杂度从O(N^3)到O(N)的算法都存在,编程珠玑、算法导论、数据结构和算法分析(C语言描述)这些书里都有谈到。

当然了这些书里的算法只管计算最大子列和(确实这样就太简单了),并没有记录相应头尾元素,还有什么全是负数还要输出整个数列首位元素(这就是为了出题而出题嘛)。但是程序的骨架是不变的。

O(N)复杂度的算法思路是:记录当前非负子列和和目前最大子列和,若前者变成了负数,便将其重置,直到遍历整个数组。这道题有一个要求:

In case that the maximum subsequence is not unique, output the one with the smallest indices i and j

需要索引最小的子列,这就要在判断条件上有精细的控制。要使得开头索引最小,就要将之前可能存在子列和为0的包含进来,而结尾索引也要最小,就要将之后可能存在子列和为0的排除,如:
2 -2 3 4 -5 5
要选取前4个,而不能包括后2个。

代码

最新代码@github,欢迎交流

#include <stdio.h>

int main()
{
    int K, n, first;
    int start, end, sum = -1;   /* the current non-negative subsequence */
    int a = -1, b, s = 0;       /* the maximum-sum subsequence */

    scanf("%d", &K);
    for(int i = 0; i < K; i++)
    {
        scanf("%d", &n);
        if(i == 0) first = n;               /* record the first number */

        /* update start, end and sum for the current non-negative subsequence */
        if(sum < 0) start = n, sum = 0;     /* reset if sum < 0 */
        sum += n;                           /* update sum */
        if(sum >= 0) end = n;               /* update end if sum >= 0 */

        /* update a, b and s for the so-far maximum-sum subsequence */
        if(sum > s || (!sum && !s))         /* special case is max-sum is 0 */
            a = start, b = end, s = sum;
    }
    /* a won't be updated if all the numbers are negative */
    if(a == -1) printf("0 %d %d", first, n);
    else        printf("%d %d %d", s, a, b);

    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 212,718评论 6 492
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 90,683评论 3 385
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 158,207评论 0 348
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,755评论 1 284
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 65,862评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,050评论 1 291
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,136评论 3 410
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,882评论 0 268
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,330评论 1 303
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,651评论 2 327
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,789评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,477评论 4 333
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,135评论 3 317
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,864评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,099评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,598评论 2 362
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,697评论 2 351

推荐阅读更多精彩内容

  • 背景 一年多以前我在知乎上答了有关LeetCode的问题, 分享了一些自己做题目的经验。 张土汪:刷leetcod...
    土汪阅读 12,740评论 0 33
  • 知乎有一个热门问题:一个女孩怎么才算精致? @王诺诺讲了一个故事,她曾经在飞机上看过一个女孩,因为要经历长时间的飞...
    穿裙子的鱼阅读 227评论 0 0
  • “池塘边的榕树上有一群知了在叫着夏天”伴随着熟悉的音乐声,夏天也悄悄地来临了。 记得小时侯,夏天的代名词就...
    biblli阅读 200评论 0 1
  • “从你描绘的整个场景图,你非常关注自己内心的情感与感觉,关注家的和睦与温馨,家是你心目中的第一位,家里氛围及家人的...
    洪雅昕阅读 265评论 0 2