天梯图书阅览室请你编写一个简单的图书借阅统计程序。当读者借书时,管理员输入书号并按下S键,程序开始计时;当读者还书时,管理员输入书号并按下E键,程序结束计时。书号为不超过1000的正整数。当管理员将0作为书号输入时,表示一天工作结束,你的程序应输出当天的读者借书次数和平均阅读时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有S没有E,或者只有E没有S的纪录,系统应能自动忽略这种无效纪录。另外,题目保证书号是书的唯一标识,同一本书在任何时间区间内只可能被一位读者借阅。
输入格式:
输入在第一行给出一个正整数N(<= 10),随后给出N天的纪录。每天的纪录由若干次借阅操作组成,每次操作占一行,格式为:
书号([1, 1000]内的整数) 键值(“S”或“E”) 发生时间(hh:mm,其中hh是[0,23]内的整数,mm是[0, 59]内整数)
每一天的纪录保证按时间递增的顺序给出。
输出格式:
对每天的纪录,在一行中输出当天的读者借书次数和平均阅读时间(以分钟为单位的精确到个位的整数时间)。
输入样例:
3
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00
输出样例:
2 196
0 0
1 60
- 注意第二个测试点不过是因为只要出现S就直接录入就好不用管之前是否已经被借走了,因为信息无效是有S没E,有E没S,所以无效的是第一个S而不是后来输入的
#include <iostream>
#include <string>
#include <stdlib.h>
#include <cstring>
#define N 1001
using namespace std;
int toMM(string str)
{
//把hh:mm格式的字符串时间转换为从00:00开始的分钟数
int h=atoi(str.substr(0,2).c_str());
int m=atoi(str.substr(3,2).c_str());
return h*60+m;
}
int main()
{
string time[N];
char status[N];
int d;cin>>d;
int book;
char oper;
string t;
for(int i=0;i<d;++i)
{
int coun=0;
int sumtime=0;
memset(status,'E',sizeof(status));
cin>>book;
while(book){
cin>>oper;
cin>>t;
if(oper=='S'){
status[book]='S';
time[book]=t;
}else{
if(status[book]=='S'){
status[book]='E';
++coun;
sumtime+=toMM(t)-toMM(time[book]);
}
}
cin>>book;
}
cin>>oper>>t;
if(i)
cout<<endl;
cout<<coun<<" ";
if(coun){
int ans=sumtime*1.0/coun+0.5;
cout<<ans;
}
else
cout<<0;
}
return 0;
}