原题目
With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namelyW
for win,T
for tie, andL
for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.
For example, 3 games' odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy
W
for the 3rd game,T
for the 2nd game, andT
for the 1st game. If each bet takes 2 yuans, then the maximum profit would be yuans (accurate up to 2 decimal places).
Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to
W
,T
andL
.
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31
题目大意
好多单词都看不懂,但是知道是赌球就行了。给你两块钱和三场比赛的赔率,求能获得最大利益的买法,以及能获得的最大利益。输入三行每行三个浮点数,分别表示该场比赛胜利、平局、失败的赔率。输出每场比赛能获利最大的买法(W、T或L),用空格隔开,最后输出能获得的最大利益。
题解
题目长得吓人,但是算法却简单得要死。
C语言代码如下:
#include<stdio.h>
int main(){
float num[3];
for(int i = 0;i < 3;++i){
float t1, t2, t3;
scanf("%f%f%f", &t1, &t2, &t3);
if(t1 > t2){
if(t1 > t3){
num[i] = t1;
printf("W ");
}
else{
num[i] = t3;
printf("L ");
}
}
else{
if(t2 > t3){
num[i] = t2;
printf("T ");
}
else{
num[i] = t3;
printf("L ");
}
}
}
printf("%.2f\n", 2*(num[0]*num[1]*num[2]*0.65 - 1));
return 0;
}