华为PPPOE配置

一、实验拓扑

image.png

二、设备配置

  • PPPOE Client主要配置:
<PPPOEClient>display current-configuration 
[V200R003C00]
#
 sysname PPPOEClient
#
interface Dialer1
 link-protocol ppp
 ppp pap local-user huawei password cipher %$%$'ub%HNMSBRG\~GP&3J6J,.RN%$%$ 
 ip address ppp-negotiate
 dialer user huawei
 dialer bundle 1
 dialer-group 1
#
interface GigabitEthernet0/0/0
 pppoe-client dial-bundle-number 1 
#
dialer-rule
 dialer-rule 1 ip permit
#
return
<PPPOEClient>   
  • PPPOE Server主要配置:
<PPPOEServer>display current-configuration 
[V200R003C00]
#
 sysname PPPOEServer
#
ip pool pool-pppoe
 gateway-list 10.1.1.1 
 network 10.1.1.0 mask 255.255.255.0 
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user huawei password cipher %$%$z"(j7ltzQJ3W,3+z"6'51OkN%$%$
 local-user huawei service-type ppp
#
interface Virtual-Template0
 ppp authentication-mode pap 
 remote address pool pool-pppoe
 ip address 10.1.1.1 255.255.255.0 
#
interface GigabitEthernet0/0/0
 pppoe-server bind Virtual-Template 0
#
return
<PPPOEServer>  

三、实验结果

  • PPPOE客户端查看拨号状态
<PPPOEClient>display pppoe-client session summary 
PPPoE Client Session:
ID   Bundle  Dialer  Intf             Client-MAC    Server-MAC    State
1    1       1       GE0/0/0          00e0fc3122b7  00e0fce54c0d  UP    
<PPPOEClient>display ip int brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 2
The number of interface that is DOWN in Protocol is 3

Interface                         IP Address/Mask      Physical   Protocol  
Dialer1                           10.1.1.254/32        up         up(s)     
GigabitEthernet0/0/0              unassigned           up         down      
GigabitEthernet0/0/1              unassigned           down       down      
GigabitEthernet0/0/2              unassigned           down       down      
NULL0                             unassigned           up         up(s)     
<PPPOEClient>ping 10.1.1.1
  PING 10.1.1.1: 56  data bytes, press CTRL_C to break
    Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=100 ms
    Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=30 ms
    Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=30 ms
    Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=20 ms
    Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=20 ms

  --- 10.1.1.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 20/40/100 ms

<PPPOEClient>
  • PPPOE服务端查看回话状态
<PPPOEServer>display access-user 
 ------------------------------------------------------------------------------
 UserID Username                       IP address                   MAC  
 ------------------------------------------------------------------------------
 146    huawei                         -                         00e0-fc31-22b7 
 ------------------------------------------------------------------------------
 Total 1,1 printed
<PPPOEServer>display access-user user-id 146

Basic:
  User id                         : 146
  User name                       : huawei
  Domain-name                     : default                         
  User MAC                        : 00e0-fc31-22b7
  User IP address                 : 254.1.1.10
  User vpn-instance               : -
  User access Interface           : Virtual-Template0:0
  QinQVlan/UserVlan               : 0/0
  User access time                : 2019/11/15 13:12:40
  User accounting session ID      : PPPOESe00000000000000c71ace000146
  User access type                : PPPoE

AAA:
  User authentication type        : PPP    authentication
  Current authentication method   : Local
  Current authorization method    : -
  Current accounting method       : None

<PPPOEServer>display interface brief 
PHY: Physical
*down: administratively down
(l): loopback
(s): spoofing
(b): BFD down
^down: standby
(e): ETHOAM down
(d): Dampening Suppressed
InUti/OutUti: input utility/output utility
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
GigabitEthernet0/0/0        up    down        0%     0%          0          0
GigabitEthernet0/0/1        down  down        0%     0%          0          0
GigabitEthernet0/0/2        down  down        0%     0%          0          0
NULL0                       up    up(s)       0%     0%          0          0
Virtual-Template0           up    up          0%     0%          0          0
<PPPOEServer>display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 2
The number of interface that is DOWN in Protocol is 3

Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              unassigned           up         down      
GigabitEthernet0/0/1              unassigned           down       down      
GigabitEthernet0/0/2              unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Virtual-Template0                 10.1.1.1/24          up         up        
<PPPOEServer>

四、PPPOE会话阶段

  • 开启debug
<PPPOEServer>terminal monitor 
Info: Current terminal monitor is on.
<PPPOEServer>terminal debugging 
Info: Current terminal debugging is on.
<PPPOEServer>debugging pppoe-server event 
  • PPPOE用户强制下线
[PPPOEServer-aaa]cut access-user user-id 146
Info: Total 1  user(s) being cut.
[PPPOEServer-aaa]
Nov 15 2019 13:32:38-08:00 PPPOEServer %%01IFNET/4/LINK_STATE(l)[4]:The line pro
tocol PPP on the interface Virtual-Template0:0 has entered the DOWN state. 
[PPPOEServer-aaa]
Nov 15 2019 13:32:38-08:00 PPPOEServer %%01IFNET/4/LINK_STATE(l)[5]:The line pro
tocol PPP IPCP on the interface Virtual-Template0:0 has entered the DOWN state. 

[PPPOEServer-aaa]
Nov 15 2019 13:32:38.411.1-08:00 PPPOEServer PPPOE/7/debug2:
  2019-11-15 13:32:38.411: PPPoE Event: GigabitEthernet0/0/0, session 1(Virtual-
Template0:0), OUT PADT packet 
  • PPPOE上线会话
[PPPOEServer-aaa]
Nov 15 2019 13:32:38.411.2-08:00 PPPOEServer PPPOE/7/debug2:
  2019-11-15 13:32:38.411: PPPoE Event: GigabitEthernet0/0/0, session 1(Virtual-
Template0:0), VPDN session deleted 

[PPPOEServer-aaa]
Nov 15 2019 13:32:53.641.1-08:00 PPPOEServer PPPOE/7/debug2:
  2019-11-15 13:32:53.641: PPPoE Event: GigabitEthernet0/0/0, IN PADI packet 

[PPPOEServer-aaa]
Nov 15 2019 13:32:53.641.2-08:00 PPPOEServer PPPOE/7/debug2:
  2019-11-15 13:32:53.641: PPPoE Event: GigabitEthernet0/0/0, OUT PADO packet 

[PPPOEServer-aaa]
Nov 15 2019 13:32:53.661.1-08:00 PPPOEServer PPPOE/7/debug2:
  2019-11-15 13:32:53.661: PPPoE Event: GigabitEthernet0/0/0, IN PADR packet 

[PPPOEServer-aaa]
Nov 15 2019 13:32:53.661.2-08:00 PPPOEServer PPPOE/7/debug2:
  2019-11-15 13:32:53.661: PPPoE Event: GigabitEthernet0/0/0, session 1(Virtual-
Template0:0), VPDN session created 

[PPPOEServer-aaa]
Nov 15 2019 13:32:53.661.3-08:00 PPPOEServer PPPOE/7/debug2:
  2019-11-15 13:32:53.661: PPPoE Event: GigabitEthernet0/0/0, session 1(Virtual-
Template0:0), OUT PADS packet 

[PPPOEServer-aaa]
Nov 15 2019 13:32:53-08:00 PPPOEServer %%01IFNET/4/LINK_STATE(l)[6]:The line pro
tocol PPP on the interface Virtual-Template0:0 has entered the UP state. 
[PPPOEServer-aaa]
Nov 15 2019 13:32:53-08:00 PPPOEServer %%01IFNET/4/LINK_STATE(l)[7]:The line pro
tocol PPP IPCP on the interface Virtual-Template0:0 has entered the UP state. 
[PPPOEServer-aaa]q
[PPPOEServer]q
<PPPOEServer>undo debugging 
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 199,393评论 5 467
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 83,790评论 2 376
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 146,391评论 0 330
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 53,703评论 1 270
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 62,613评论 5 359
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,003评论 1 275
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,507评论 3 390
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,158评论 0 254
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,300评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,256评论 2 317
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,274评论 1 328
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,984评论 3 316
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,569评论 3 303
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,662评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,899评论 1 255
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,268评论 2 345
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 41,840评论 2 339

推荐阅读更多精彩内容