Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? !
Input
The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31
).
Sample Input
15 101 2 3 4 55 4 3 2 1
Sample Output
14
//核心代码
// for(i = 1; i<=n; i++)
// {
// for(j = v;j>=s[i];j--)
// {
// dp[j] = max(dp[j],dp[j-s[i]]+x[i]);
}
// }
#include<stdio.h>
#include <algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
int t,i,j,n,v;
int x[1005],s[1005],dp[1005];
scanf("%d",&t);
while(t--)
{
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&v);
for(i=1;i<=n;i++)
{
scanf("%d",&x[i]);
}
for(j=1;j<=n;j++)
{
scanf("%d",&s[j]);
}
for(i = 1; i<=n; i++)
{
for(j = v;j>=s[i];j--)
{
dp[j] = max(dp[j],dp[j-s[i]]+x[i]);
}
}
printf("%d\n",dp[v]);
}
}