1026 Table Tennis (30 分)PTA甲级 测试点分析

题目链接

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.
Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.
One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:
9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2
Sample Output:
08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2

题目大意

k张桌子,球员到达后总是选择编号最小的桌子。如果训练时间超过2h会被压缩成2h,如果到达时候没有球桌空闲就变成队列等待。k张桌子中m张是vip桌,如果vip桌子有空闲,而且队列里面有vip成员,那么等待队列中的第一个vip球员会到最小的vip球桌训练。如果vip桌子空闲但是没有vip来,那么就分配给普通的人。如果没有vip球桌空闲,那么vip球员就当作普通人处理。
给出每个球员的到达时间、要玩多久、是不是vip(是为1不是为0)。给出球桌数和所有vip球桌的编号,QQ所有在关门前得到训练的球员的到达时间、训练开始时间、等待时长(取整数,四舍五入),营业时间为8点到21点。如果再21点后还没有开始玩的人,就不再玩,不需要输出~
————————————————
摘自CSDN博主「柳婼」的原创文章
原文链接:https://blog.csdn.net/liuchuo/article/details/54576965

测试点分析

一开始错了四个点:测试点3、测试点5、测试点7、测试点8

测试点3:只有一个人来并关门了
//  测试点3样例
1
21:00:00 10 1
3 0
测试点5、7:都是vip用户要选择第一张空闲的vip桌,注意时间可以取等,即刚好打完到了
测试点8:最后计算等待时间的时候>=30向上进1,用(start-arrive+30)/60就行了

AC代码

#include<bits/stdc++.h>
using namespace std;

struct cus{
    int arri, play, vip;
    int start;
};

bool cmp1(cus a, cus b){
    return a.arri < b.arri;
}

bool cmp2(cus a, cus b){
    return a.start<b.start;
}

void prt(int x){
    int h, m, s;
    h = x/3600;
    m = x/60 -h*60;
    s = x%60;
    printf("%02d:%02d:%02d ", h, m, s);
}

int main(){
    int n, m, k;
    scanf("%d", &n);
    vector<cus> data(n);
    for(int i=0; i<n; i++){
        int h, m, s;
        scanf("%d:%d:%d %d %d", &h, &m, &s, &data[i].play, &data[i].vip);
        data[i].play = min(120, data[i].play)*60; //测试点4
        data[i].arri = h*3600 + m*60 +s;
    }
    scanf("%d %d", &m, &k);
    vector<int> times(m, 8*3600);
    vector<int> cnt(m);
    vector<bool> is_vip(m, false);
    for(int i=0; i<k; i++){
        int t;
        scanf("%d", &t);
        is_vip[t-1] = true;
    }
    sort(data.begin(), data.end(), cmp1);
    for(int i=0; i<n; i++){
        if(data[i].start) continue;
        int mint=21*3600, table=-1, player=i;
        for(int j=0; j<m; j++){
            if(times[j]<mint){
                table = j;
                mint = times[j];
            }
        }
        if(table==-1) data[i].start = mint;
        else{
            if(is_vip[table]&&!data[i].vip){
                for(int j=i; j<n&&data[j].arri<=mint&&player==i; j++) if(data[j].vip&&!data[j].start) player=j;
                if(player!=i) i--;
            }
            else if(data[i].vip&&!is_vip[table]){
                for(int j=0; j<m; j++){ //测试点5在vip用户用第一张空闲的vip桌
                    if(times[j]<=data[i].arri&&is_vip[j]){ //测试点7在这个等于号
                        table = j; break;
                    }
                }
            }
            data[player].start = max(mint, data[player].arri);
            times[table] = data[player].start + data[player].play;
            if(data[player].start<21*3600) cnt[table]++; //测试点3在这个判断,第一个用户就超过21点不能计数
        }
    }
    sort(data.begin(), data.end(), cmp2);
    for(int i=0; i<n; i++){
        if(data[i].start>=21*3600) continue;
        prt(data[i].arri);
        prt(data[i].start);
        printf("%d\n", (data[i].start-data[i].arri+30)/60);     //测试点8在这个分钟的四舍五入
    }
    for(int i=0; i<m; i++) printf("%d%s", cnt[i], i==m-1?"\n":" ");
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 211,290评论 6 491
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 90,107评论 2 385
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 156,872评论 0 347
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,415评论 1 283
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 65,453评论 6 385
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 49,784评论 1 290
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,927评论 3 406
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,691评论 0 266
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,137评论 1 303
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,472评论 2 326
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,622评论 1 340
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,289评论 4 329
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,887评论 3 312
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,741评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,977评论 1 265
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,316评论 2 360
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,490评论 2 348

推荐阅读更多精彩内容