题目信息
Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106.The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
代码
#include<iostream>
using namespace std;
int main(){
int a,b;
cin>>a>>b;
string s=to_string(a+b);
for(int i=0;i<s.length();i++){
cout<<s[i];
if(s[i]=='-') continue;
if((i+1)%3==s.length()%3&&i!=s.length()-1) cout<<",";
}
return 0;
}
测试结果
image.png