poj2139 Six Degrees of Cowvin Bacon

题目:

Description
The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input

  • Line 1: Two space-separated integers: N and M * Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
    Output
  • Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
    Sample Input
    4 2
    3 1 2 3
    2 3 4
    Sample Output
    100
    Hint
    [Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

题目是说N头牛去拍M部电影,每部电影都有相应的牛当演员。
同一部电影的演员两两有关系,不同的电影中的演员没有关系(关系的权值为1)。
问题是对于每头牛与其他牛的关系之和求出最小的并且*100再除以N-1.

此题由于N的值不是很大,因此可以用Floyd-Warshall算法解决,将任意2头牛之间的关系求出,然后求出每头牛与其他牛的关系总和,最后比较即可,然后进行相应的处理。

参考代码:

#include <iostream>
#include <algorithm>
#define N 320
#define INF 99999
using namespace std;
int d[N][N];
void cl(int n) {
    for (int i = 1;i <= n;++i) {
        for (int j = 1;j <= n;++j) {
            d[i][j] = INF;
        }
    }
    for (int i = 1;i <= n;++i) {
        d[i][i] = 0;
    }
}
void floyed(int n) {
    for (int k = 1;k <= n;++k) {
        for (int i = 1;i <= n;++i) {
            for (int j = 1;j <= n;++j) {
                d[i][j] = min(d[i][j],d[i][k]+d[k][j]);
            }
        }
    }   
}
int minways(int n) {
    int minw = 99999;
    int w;
    for (int i = 1;i <= n;++i) {
        w = 0;
        for (int j = 1;j <= n;++j) {
            if (i != j && d[i][j] != INF) w = w + d[i][j];
            //cout << w << endl;    
        }
        //cout << w << endl;
        if (w < minw) minw = w;
    }
    return minw;
}
int average(int minw,int n) {
    int aver;
    aver = minw * 100 / (n-1);
    return aver;
} 
int main() {
    int n,m;
    while (cin >> n >> m) {
        cl(n);
        int num1;
        int cows[N];
        for (int i = 1;i <= m;++i) {
            cin >> num1;
            int k = 1;
            for (int j = 1;j <= num1;++j) {
                cin >> cows[k];
                k++;
            }
            for (int i1 = 1;i1 < k;++i1) {
                for (int i2 = 1;i2 < k;++i2) {
                    if (cows[i1] != cows[i2]) {
                        d[cows[i1]][cows[i2]] = 1;
                    }
                }
            }
        }
        floyed(n);
        int minw = minways(n);
        //cout << minw << endl;
        int aver = average(minw,n);
        cout << aver << endl;
    }
    return 0;
}

此题也可以用其他方法求出结果,这里就不再列出了。

话说poj里的牛真屌,又开party又拍电影,还办学校,甚至探索虫洞的奥秘,比我们还厉害。这年头,不好好学习,连牛都要鄙视你。

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 195,783评论 5 462
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 82,360评论 2 373
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 142,942评论 0 325
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,507评论 1 267
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,324评论 5 358
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,299评论 1 273
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,685评论 3 386
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,358评论 0 254
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,652评论 1 293
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,704评论 2 312
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,465评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,318评论 3 313
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,711评论 3 299
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,991评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,265评论 1 251
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,661评论 2 342
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,864评论 2 335

推荐阅读更多精彩内容