PAT甲级JAVA版 1003 Emergency(25 分)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C_{1}and C_{2}- the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers C_{1},C_{2}and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C_{1} to C_{2}.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C_{1} and C_{2}, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

1003 紧急情况 (25 分)

作为一个城市的紧急救援队队长,你会得到一张你国家的特殊地图。这张地图显示了几个分散的城市与一些道路相连。每个城市的救援队数量和每一对城市之间每条道路的长度在地图上都有标记。当有来自其他城市的紧急电话给你时,你的工作就是尽快地把你的人带到那个地方,同时,在路上获得尽可能多的救援队。

输入规格

每个输入文件包含一个测试用例。对于每个测试用例,第一行包含4个正整数:N(≤500)-城市数量(城市编号为0到N−1),M-道路数,C_{1}C_{2}--分别是您当前所在的城市和必须拯救的的城市。下一行包含N个整数,其中第i个整数是第i城市的救援队数目。接下来有M行,每行用三个整数C_{1}C_{2}和L描述一条道路,三个整数分别是那条道路相连的一对城市编号和那条道路的长度。数据保证了至少有一个路径能C_{1}C_{2}

输出规格

对于每个测试用例,在一行中打印两个数字:在C_{1}C_{1}之间的不同最短路径的数目,以及您可能收集到的最大救援队数量。一行中的所有数字都必须用一个空格隔开,在一行的末尾不允许有额外的空格。

输入样例

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

输出样例

2 4

代码

import java.util.Arrays;
import java.util.Scanner;

public class Main {
    private static Scanner sc;

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        sc = new Scanner(System.in);
        final int inf = 99999999;
        int n, m, c1, c2;
        int[] dis = new int[510];
        Arrays.fill(dis, inf);

        int[][] e = new int[510][510];
        // Arrays.fill(e, dis);
        for (int i = 0; i < e.length; i++) {
            for (int j = 0; j < e.length; j++) {
                e[i][j] = inf;
            }
        }
        int[] weight = new int[510];
        int[] num = new int[510];
        int[] w = new int[510];
        boolean[] visit = new boolean[510];
        Arrays.fill(visit, false);
        n = sc.nextInt();
        m = sc.nextInt();
        c1 = sc.nextInt();
        c2 = sc.nextInt();
        for (int i = 0; i < n; i++) {
            weight[i] = sc.nextInt();
        }

        int a, b, c;
        for (int i = 0; i < m; i++) {
            a = sc.nextInt();
            b = sc.nextInt();
            c = sc.nextInt();
            e[a][b] = e[b][a] = c;
        }
        sc.close();
        dis[c1] = 0;
        w[c1] = weight[c1];
        num[c1] = 1;

        for (int i = 0; i < n; i++) {
            int u = -1, min = inf;
            for (int j = 0; j < n; j++) {
                if (visit[j] == false && dis[j] < min) {
                    u = j;
                    min = dis[j];
                }
            }
            if (u == -1)
                break;
            visit[u] = true;
            for (int v = 0; v < n; v++) {
                if (visit[v] == false && e[u][v] != inf) {
                    if (dis[u] + e[u][v] < dis[v]) {
                        dis[v] = dis[u] + e[u][v];
                        num[v] = num[u];
                        w[v] = w[u] + weight[v];
                    } else if (dis[u] + e[u][v] == dis[v]) {
                        num[v] = num[v] + num[u];
                        if (w[u] + weight[v] > w[v])
                            w[v] = w[u] + weight[v];
                    }
                }
            }
        }

        System.out.print(num[c2] + " " + w[c2]);
    }
}

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 212,686评论 6 492
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 90,668评论 3 385
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 158,160评论 0 348
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,736评论 1 284
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 65,847评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,043评论 1 291
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,129评论 3 410
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,872评论 0 268
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,318评论 1 303
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,645评论 2 327
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,777评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,470评论 4 333
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,126评论 3 317
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,861评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,095评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,589评论 2 362
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,687评论 2 351

推荐阅读更多精彩内容