题目
1004 Counting Leaves (30 分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
分析
这道题主要考察的是dfs的运用,因为在树中是不会有回路的,所以dfs过程中不需要辅助数组vis,在dfs中需要考虑level也就是每一层树中叶子节点的个数,所以多加一个level参数。退出条件是遍历到叶子结点(叶子节点没有子树了),同时要存储一个最大的level数,用于输出level数组。
解法中使用二维数组来存储树的结构
代码
#include<iostream>
#include<vector>
using namespace std;
#define maxn 101
vector<int>node[maxn];
int level[maxn]={0};
int maxlevel=0;
void dfs(int n,int l){
if(node[n].size()==0){
level[l]++;
if(l>maxlevel)
maxlevel=l;
return;
}
for(int i=0;i<node[n].size();i++){
dfs(node[n][i],l+1);
}
}
int main(){
int n,m;
cin>>n>>m;
for(int i=0;i<m;i++){
int u,k;
cin>>u>>k;
for(int j=0;j<k;j++){
int x;
cin>>x;
node[u].push_back(x);
}
}
dfs(1,0);
cout<<level[0];
for(int i=1;i<=maxlevel;i++){
cout<<" "<<level[i];
}
}