Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
1 2
-3 1
2 11 2
0 20 0
Sample Output
Case 1: 2
Case 2: 1
题意:
假设海岸线是一条无限延伸的直线。陆地在海岸线的一侧,而海洋在另一侧。每一个小的岛屿是海洋上的一个点。雷达坐落于海岸线上,只能覆盖d距离,所以如果小岛能够被覆盖到的话,它们之间的距离最多为d。题目要求计算出能够覆盖给出的所有岛屿的最少雷达数目。
解题思路:
我们假设岛屿i它的x坐标为island[i][0],而y坐标为island[i][1],那么有以下几种情况是invalide的,即输出-1的情况:
1.island[i][1]<0
2.abs(island[i][1])>d
3.d<0
其他的情况,应该就是正常情况,进入计算最小雷达数目。
如上图,红色的点为岛屿,那么能够覆盖到此岛屿的雷达所在的区间,应该就是以该岛屿为圆心的圆与x轴交点所在的区间。
这样,我们就可以计算出所有岛屿的雷达所在的区间,得到一个区间数组。
我们将这个数组按照区间左部分进行排序,那么重叠部分就表明这些岛屿的雷达可以共用一个。从而计算出最终解。
可以把所有的岛的坐标通过x(+ -)sqrt(d*d-y*y)得出可以扫射到它的雷达的区域范围,在对右坐标进行排序。
但是千万不要忘记还有右坐标相等的情况,这种时候你知道肯定要选区间小的范围(一定可以扫射到区间范围大的岛),即让左坐标大的排在前面。
拍完序后,你就要用到贪心法,每次都贪心的选择最右端的点作为判断点,循环到最后,可以得出最少的雷达数。
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#define MAX 1005
using namespace std;
struct note{
double left,right;
}b[MAX];
bool cmp(note a,note b) //结构体排序
{
if(a.right==b.right) return a.left>b.left;
else
return a.right<b.right;
}
int acount,n;
void search(double maxn) //找到最少的雷达数
{
int i;
for(i=1;i<n;i++)
if(b[i].left>maxn)
{
maxn=b[i].right; //都取最右端
acount++;
}
}
int main()
{
double d,x,y;
scanf("%d%lf",&n,&d);
int t=0;
while(n||d)
{
t++;
int o=0;
acount=0;
for(int i=0;i<n;i++)
{
scanf("%lf%lf",&x,&y);
if(y>d) //判断是否可以扫射到岛
o++;
b[i].left=x-sqrt((d*d)-(y*y)); //预处理,变成区间
b[i].right=x+sqrt((d*d)-(y*y));
}
if(!o)
{
sort(b,b+n,cmp);
search(b[0].right);
printf("Case %d: %d\n",t,acount+1);
}
else
printf("Case %d: -1\n",t);
scanf("%d%lf",&n,&d);
}
return 0;
}