HDU4768——Flyer

Problem

The new semester begins! Different kinds of student societies are all trying to advertise themselves, by giving flyers to the students for introducing the society. However, due to the fund shortage, the flyers of a society can only be distributed to a part of the students. There are too many, too many students in our university, labeled from 1 to 2^32. And there are totally N student societies, where the i-th society will deliver flyers to the students with label A_i, A_i+C_i,A_i+2C_i,…A_i+kC_i (A_i+kC_i<=B_i, A_i+(k+1)C_i>B_i). We call a student "unlucky" if he/she gets odd pieces of flyers. Unfortunately, not everyone is lucky. Yet, no worries; there is at most one student who is unlucky. Could you help us find out who the unfortunate dude (if any) is? So that we can comfort him by treating him to a big meal!

Input

There are multiple test cases. For each test case, the first line contains a number N (0 < N <= 20000) indicating the number of societies. Then for each of the following N lines, there are three non-negative integers A_i, B_i, C_i (smaller than 2^31, A_i <= B_i) as stated above. Your program should proceed to the end of the file.

Output

For each test case, if there is no unlucky student, print "DC Qiang is unhappy." (excluding the quotation mark), in a single line. Otherwise print two integers, i.e., the label of the unlucky student and the number of flyers he/she gets, in a single line.

Sample Input

2
1 10 1
2 10 1
4
5 20 7
6 14 3
5 9 1
7 21 12

Sample Output

1 1
8 1


思路一

做这道题时候的想法,因为乍一看最多一个奇数,直接暴力异或就好。

代码一

#include <iostream>
#include <cstring>
using namespace std;
const int N=2e4+5;
long long a[N],b[N],c[N];
int main(){
  ios::sync_with_stdio(false);
  cin.tie(0);
  long long n,res,sum;
  while(cin>>n){
    res=sum=0;
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    memset(c,0,sizeof(c));
    for(long long i=1;i<=n;i++)cin>>a[i]>>b[i]>>c[i];
    for(long long i=1;i<=n;i++){
      for(long long j=a[i];j<=b[i];j+=c[i])res^=j;
    }
    if(res){
      for(long long i=1;i<=n;i++){
        if(res>=a[i]&&res<=b[i]&&(res-a[i])%c[i]==0)++sum;
      }
      cout<<res<<" "<<sum<<endl;
    }
    else cout<<"DC Qiang is unhappy."<<endl;
  }
  return 0;
}

思路二

代码一通过没问题,不过后来经过学长提醒,这道题正确的思路是二分——所有组中最小编号为下界,最大B为上界,二分条件是所有组从A到mid(二分中点) 得到玩具的个数和为奇数时,则奇数小朋友在low--mid里,否则在mid--high里(如果有的话)。
因为如果mid之前小朋友有一个得到奇数的话,之前所有小朋友得到玩具数一定为奇,否则为偶 (偶+偶得偶,偶+奇得奇数) 。这是因为题目说了有的话只有一个奇数,如果有多个的话奇+奇得奇,就不能这么去做了。

代码二

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 2e4+5;
int n;
long long l[N],r[N],k[N];
long long deal(long long x,long long y,long long z){
    return 1 + (y - x)/z;
}
int got(long long x){
    int cnt = 0;
    for(int i = 1;i <= n;i++)
     if(l[i] <= x && r[i] >= x)
      if(x % k[i] == l[i] % k[i]) cnt++;
    return cnt;
}
long long check(long long mid){
    long long cnt = 0;
    for(int i = 1;i <= n;i++)
     if(l[i] <= mid) cnt += deal(l[i],min(r[i],mid),k[i]);
    return cnt;
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin>>n){
        long long x = 1,y = 1;
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        memset(k,0,sizeof(k));
        for(int i = 1;i <= n;i++){
            cin>>l[i]>>r[i]>>k[i];
            y = max(y, r[i]);
        }
        while(x != y){
            long long mid = (x+y)>>1;
            if(check(mid) & 1) y = mid;
            else x = mid+1;
        }
        if(check(x) & 1) cout<<x<<" "<<got(x)<<endl;
        else cout<<"DC Qiang is unhappy."<<endl;
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 211,042评论 6 490
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 89,996评论 2 384
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 156,674评论 0 345
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,340评论 1 283
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 65,404评论 5 384
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 49,749评论 1 289
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,902评论 3 405
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,662评论 0 266
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,110评论 1 303
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,451评论 2 325
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,577评论 1 340
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,258评论 4 328
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,848评论 3 312
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,726评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,952评论 1 264
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,271评论 2 360
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,452评论 2 348

推荐阅读更多精彩内容

  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,429评论 0 23
  • 前不久,很长时间不联系的一个兄弟突然发消息给我,告诉我他要结婚了,当时,很惊讶,他怎么会想起结婚? 也许你会惊讶,...
    杨先生i阅读 245评论 0 2
  • 《Redis实战》--读书笔记 时间:2017年10月02日01:13:48 第1章 共有五种结构 ①String...
    MR_ChanHwang阅读 518评论 1 1
  • 今天来跟大家讨论一下何去何从这个主题,从哪里来到从哪里去,一直走一直走发现并不是你想走的那条路,想重新走心里有点胆...
    A羽翼阅读 267评论 0 1
  • 回汉后,一直还没有开始事业,对于我这种双鱼座的人来说,绝对有选择综合症,能做好一件事,真的是奇葩. 今天当了回刺客...
    大熊坤阅读 154评论 1 0