第七次寒假集训

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES
又是迷宫逃生问题,且门只能在第T秒打开。
剪枝中的奇偶剪枝


image.png

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 10
 
using namespace std;
 
bool flag,ans,visited[N][N];
int n,m,t,xe,ye;
char map0[N][N];
 
void dfs(int x,int y,int timen){
    if(flag) return ;
    if(timen>t) return ;
    if(x<0||x>n-1||y<0||y>m-1) return ;
    if(timen==t&&map0[x][y]=='D') {flag=ans=true;return ;}
    int temp=t-timen-abs(xe-x)-abs(ye-y);
    if(temp&1) return ;//奇偶剪枝
      if(!visited[x-1][y]&&map0[x-1][y]!='X'){
        visited[x-1][y]=true;
        dfs(x-1,y,timen+1);
        visited[x-1][y]=false;
    }
    if(!visited[x+1][y]&&map0[x+1][y]!='X'){
        visited[x+1][y]=true;
        dfs(x+1,y,timen+1);
        visited[x+1][y]=false;
    }
     if(!visited[x][y-1]&&map0[x][y-1]!='X'){
        visited[x][y-1]=true;
        dfs(x,y-1,timen+1);
        visited[x][y-1]=false;
    }
     if(!visited[x][y+1]&&map0[x][y+1]!='X'){
        visited[x][y+1]=true;
        dfs(x,y+1,timen+1);
        visited[x][y+1]=false;
    }
}
 
int main(){
    int xs,ys;
    while(scanf("%d%d%d",&n,&m,&t)!=EOF&&(n||m||t)){
        int cnt=0;
        getchar();
        memset(visited,false,sizeof(visited));
        flag=ans=false;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                cin>>map0[i][j];
                if(map0[i][j]=='S'){
                    xs=i;ys=j;
                    visited[i][j]=true;
                }
                if(map0[i][j]=='D'){
                    xe=i;ye=j;
                }
                if(map0[i][j]=='X'){
                    cnt++;
                }
            }
        }
        if(n*m-cnt-1>=t) dfs(xs,ys,0);
        if(ans) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

小兔的叔叔从外面旅游回来给她带来了一个礼物,小兔高兴地跑回自己的房间,拆开一看是一个棋盘,小兔有所失望。不过没过几天发现了棋盘的好玩之处。从起点(0,0)走到终点(n,n)的最短路径数是C(2n,n),现在小兔又想如果不穿越对角线(但可接触对角线上的格点),这样的路径数有多少?小兔想了很长时间都没想出来,现在想请你帮助小兔解决这个问题,对于你来说应该不难吧!
Input
每次输入一个数n(1<=n<=35),当n等于-1时结束输入。
Output
对于每个输入数据输出路径数,具体格式看Sample。
Sample Input
1
3
12
-1
Sample Output
1 1 2
2 3 10
3 12 416024

迷宫型的动态规划。
由题意的不可接触对角线但可接触对角线的规则可知,
对角线上半部分每个格子只能从左边的格子与上面的格子走来,对角线上的格子只能从上边的格子走来。则路径数的状态转移过程为
对角线上的格子:d[i][i]=d[i-1][i];
对角线外的格子:d[i][j]=d[i-1][j]+d[i][j-1];

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int n;
long long map[40][40];
int main()
{
    int i,j,cnt=1;;
    while(cin>>n&&n!=-1)
    {
        memset(map,0,sizeof(map));
        for(i=0;i<=n;++i)
            map[0][i]=1;
        for(i=1;i<=n;++i)
            for(j=0;j<=i;++j)
        {
            if(i==j)
                map[i][j]=map[i][j-1];
            else
                map[i][j]=map[i-1][j]+map[i][j-1];
        }
        printf("%d %d %I64d\n",cnt++,n,2*map[n][n]);
    }
    return 0;
}

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 219,366评论 6 508
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 93,521评论 3 395
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 165,689评论 0 356
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,925评论 1 295
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,942评论 6 392
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,727评论 1 305
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,447评论 3 420
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 39,349评论 0 276
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,820评论 1 317
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,990评论 3 337
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 40,127评论 1 351
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,812评论 5 346
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,471评论 3 331
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 32,017评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 33,142评论 1 272
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 48,388评论 3 373
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 45,066评论 2 355

推荐阅读更多精彩内容