题目信息
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
分析
哈哈,25分的题,我用流氓算法也能得20分。最后那个运行超时的测试点,因为算法复杂度是O(n^3)。考试的时候实在没有好的思路就酱紫吧。。
附上流氓代码
#include<iostream>
using namespace std;
int main(){
int k,maxsum=-9999999,l=0,r=0;
cin>>k;
int a[k];
for(int i=0;i<k;i++) cin>>a[i];
for(int i=0;i<k;i++){
for(int j=i;j<k;j++){
int sum=0;
for(int p=i;p<=j;p++) sum+=a[p];
if(sum>maxsum){
maxsum=sum;l=i,r=j;
}
}
}
if(maxsum<0) cout<<"0"<<" "<<a[0]<<" "<<a[k-1];
else cout<<maxsum<<" "<<a[l]<<" "<<a[r];
return 0;
}
柳神动态规划代码
#include<iostream>
using namespace std;
int main(){
int k;
cin>>k;
int temp=0,sum=-1,tempindex=0,left=0,right=k-1,a[k];
for(int i=0;i<k;i++){
cin>>a[i];
temp+=a[i];
if(temp<0){
temp=0;tempindex=i+1;
}else if(temp>sum){
sum=temp;
left=tempindex;
right=i;
}
}
if(sum<0) sum=0;
cout<<sum<<" "<<a[left]<<" "<<a[right];
return 0;
}